Announcement

Collapse
No announcement yet.

IOS: invalid certificate after last update 1.4.11

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • IOS: invalid certificate after last update 1.4.11

    IOS publishing error "A valid provisioning profile for this executable was not found"

    After the software update 1.4.11 I can no longer install any app made with tiger on my ios development devices: ipad and iphone.

    The compilation is done correctly, but the app is not copied to the device producing the error.

    With the previous version I had no problem and the compiled apps were installed correctly on the devices.

    I have an enterprice developer license and the certificates used are always the same. I also use the framework "corona sdk" and "unity", I have compiled the app with the same certificate used with tiger and the compiled app installs without problems. I need feedback as soon as possible.
    Xcode version 10.2.1

    Regards
    Last edited by Alter; 2019-04-24, 12:19.

  • #2
    What iOS version are you running on your device?

    Comment


    • #3
      We did some further tests. We found that we had some problems with some older provisioning profiles. We generated new provisioning profiles and that fixed it on our side. So far we tested the following scenarios and it worked there everytime:
      • High Sierra, XCode 10.1
      • Mojave, XCode 10.1
      • Mojave, XCode 10.2.1
      Note that XCode 10.1 is the last version supporting High Sierra, which is also the reason why the templates were created with this version.

      Comment


      • #4
        Hi Kevin,
        Sorry for the delay in answering:
        This is my system, see img, i have re-generated my provisioning but same error, also make a new provisioning profile with new id:

        Comment


        • #5
          Ok that's very strange. Please send me your export log and hopefully I can find something in there:
          1. Publish for iOS just as before.
          2. Open the console:
          3. Screen Shot 2019-04-30 at 08.44.26.png
          4. After the export is done, click Options in the newly opened console (down left) and in there save file
          5. Send me this file to our support mail adress.

          Comment


          • #6
            Hi Kevin, ok i have send a email with consolemessage.txt
            Thank you
            Pasquale

            Comment


            • #7
              Thanks, I got your mail. I had a look into it, but found nothing unusual so far.

              Comment


              • #8
                It seems that this is a common problem with other users who switched to either XCode 10.1+ and/or Mojave as can be seen here https://stackoverflow.com/questions/52424462/xcode-10-a-valid-provisioning-profile-for-this-executable-was-not-found/52499149


                With the recent 1.4.11 we updated XCode on our side to 10.1, which we needed to do to keep compatibility with the newest iOS versions. It seems that this causes problems for some users. Here some things you could try and/or check out of the above link:
                1. Use the menu "Xcode -> Preferences ... -> Accounts" and make sure all accounts you use are logged in so the provisioning profiles are accessible.
                2. Create a new AppID and corresponding provisioning profile and see if this works on your device.

                Comment


                • #9
                  I've also prepared a template build using the legacy build system as described in the link above. Note that this is just a quick test build and would need further testing, if it works on your side.
                  1. Download it here: https://www.dropbox.com/s/n328u3jdav...e.app.zip?dl=0
                  2. Unzipp it and replace the EinzelappTemplate.app file here <Path-to-your-Publishing-Tools>/TC2Tools/Templates/iOS/ with the new one
                  3. Publish as before

                  Comment


                  • #10
                    We found another - rather obscure - bug, which could be related to your problem. The fix is included in our 1.4.12 update.

                    Comment

                    Working...
                    X